I installed cryoSPARC version v3.1.0 on ubuntu with standalone option. When I run nvidia-smi, it shows Driver Version 410.104 and CUDA Version 10.0 which are compatible. In installation command, I also passed the available cuda-10.0 as cudapath option. However, when I run an ab-initio reconstruction job, it returns skcuda.cudart.cudaErrorInsufficientDriver. Based on this link, this issue relates to incompatible driver and cudatoolkit. But in my case, it seems that cuda and driver version are compatible. By the way, when I looked at cudatoolkit installed in environment of cryosparc_worker_env, its version was 10.1. I suspect that may be the reason for this issue. I tried many things to change this but not yet successful. Thank you.

Why not just upgrade your nvidia driver?

As I don’t have root access, I was just looking for a quick solution. Any way, if the driver and cuda shown by nvidia-smi are compatible, why upgrading the driver might help?


Your nvidia driver is too old for CUDA 10.1, and the cryosparc worker is using it’s own version of CUDA, which appears to be 10.1. This driver is at least 4 revisions behind the current one (I’m using 460.67). Find someone with root access to upgrade your nvidia driver.

1 Like

I got it. Thank you so much for the clarification. So it seems that the latest version of cryosparc requires >= cuda-10.1. I will contact the person with root access and ask him to upgrade cuda and nvidia driver.

1 Like