Server error when starting master

Hi all,

I get this error when trying to start the master process. Any ideas?

cryosparcm start
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: started
command_core: started

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

command_vis: started
command_proxy: started
webapp: started

Hey @suzannescott,

Can you try running a restart command?

cryosparcm restart

This error can show up when the database isn’t actually fully started but gets a request from command_core to initialize the db engine.

Hi @stephan ,

Unfortunatley this doesn’t seem to work either - I get the same error. I also tried restarting the computer but that didn’t seem to make any difference.


Hi @suzannescott,

Are there any errors when you inspect the logs via cryosparcm log command_core ?

- Suhail

Hi @sdawood

Yes, there is an error:

COMMAND CORE STARTED === 2018-10-15 11:28:43.399352 ==========================
[2018-10-15 11:28:43,893] ERROR in app: Exception on /startup [GET]
Traceback (most recent call last):
File “/cryosparc_path/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/flask/”, line 1982, in wsgi_app
response = self.full_dispatch_request()
File “/cryosparc_path/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/flask/”, line 1614, in full_dispatch_request
rv = self.handle_user_exception(e)
File “/cryosparc_path/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/flask/”, line 1517, in handle_user_exception
reraise(exc_type, exc_value, tb)
File “/cryosparc_path/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/flask/”, line 1612, in full_dispatch_request
rv = self.dispatch_request()
File “/cryosparc_path/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/flask/”, line 1598, in dispatch_request
return self.view_functionsrule.endpoint
File “cryosparc2_command/command_core/”, line 241, in startup
mongo.db[‘users’].update_one({’_id’:user[’_id’]}, {’$set’ : {‘name’: user[‘emails’][0][‘address’].strip().split(’@’)[0] }})
KeyError: ‘emails’