Refinement after 3D classification

I got a map of 3.0 A resolution after NU refinement with 165K particles. I did 3D classification to further sort them. I was able to get 4 classes out of which 3 were very similar and comprised 70% of the particles. However, I am having a problem with the refinement after the Classification where the resolution and map are getting worse. However, refinement for the remaining 1 class with 30% particles gives me a good map.
How can I fix this problem?

Have you tried refining all 4 classes separately? Maybe the first 3 classes just contained a lot of low-resolution or junk data. Or maybe it’s something else. But it’s hard to interpret “worse” or “good” without knowing what your FSC curves and other statistics look like.

Yes, I did try to refine them separately, but it didn’t help. The input for 3D classification was from NU refinement with Autotune class similarity enabled, rest of the parameters were used as default. All the refinements were done with default parameters. I did Homogeneous reconstruction only for Class 2-4, the FSC curve looks fine. However, during NU or Homogenous refinement, the FSC went bonker to Nyquist frequency. I am attaching the images of the FSC curve for NU refinements of Class 1, Class 2-4 Homogenous reconstruction only and Class 2-4 NU refinement.


It is a bit odd that reconstruction of class 2-4 gives high resolution, while refinement does not. As a quick test, I would try 2D classification of class1 vs class 2-4, to see if class 2-4 are indeed junk as the NU-refine results would suggest. Also, if you inspect the 3.8Å reconstruction of C2-4, does it have high resolution features?

What non-default settings did you use for 3D-classification (if any), and what were the final ESS values?

Yes, the 3.8Å reconstruction of C2-4, has high resolution features. I did a 2D classification of class 1 vs class 2-4, they don’t appear like junk.
I just used 3D classification with Autotune class similarity enabled, none of the other non-default settings were used. The final ESS values were || Min 1.000 | Mean 1.311 | Median 1.017 | Max 5.975

I tried local refinement of the 3.8 A reconstruction map and it gives a map of 4.1 A with high-resolution features, however following NU and Homogenous refinement gives a greater than 7 A map with spiky features which look like artefacts.

Is there a way to overcome this issue?


Hmmm that is odd… if you are using the default params for NU-refine, maybe try reducing the initial lowpass a bit, from 30A to 15A? Sometimes the default value can result in non-convergence for small particles.

I tried the initial low pass of 12A and 15A, but it didn’t help. The NU and Homogenous refinement with local refinement inputs improve the resolution from 4.1A to 3.6A in initial iterations and then go bonker in the last 2 iterations…

That is strange - anything unusual about the sample? Symmetry/pseduosymmetry? Is it a membrane protein, or does it have large mobile regions?

It’s an SSU of a ribosome. As per the 3D classification, class 2-4 has extra proteins bound to SSU which was not visible in 2D classification and Class 1 looks like canonical SSU.

Will a static mask help? If so, what parameter should I disable to stop the dynamic masking?

If it is a masking issue, you can try switching off dynamic masking completely and running without a mask - just set the resolution to start dynamic masking to 1 Å

Switching off dynamic masking didn’t help either. It is very odd that it improves the resolution in the initial iterations and goes bonker in the last 2 iterations.
Any other suggestions on how I can fix this?


Yes it is odd - is there any hint in the job log for the last two iterations? what happens immediately before the resolution drop? Did you have on-the fly CTF refinement switched on, that can cause instability sometimes?