Pycuda error after 3d-flex installation

Hello, I tried to install 3d-flex by ./bin/cryosparcw install-3dflex. After installation, it shows the no module named pycuda error and it is not fixed even I run ./bin/cryosparcw install-3dflex. How could I fix this?
Thanks a lot.

Do you have the exact error text? IIRC, 3dflex install does generate an error, but comments that this is normal and it works anyway. Try running a 3d flex job?

OK, just had this happen on a system I’ve been loath to update so was running a seriously out of date release.

What worked:

Make sure which nvcc returns null (CUDA not in $PATH or $LD_LIBRARY_PATH), then;

cryosparcm update
cd /path/to/cryosparc-worker
./bin/cryosparcw forcedeps
./bin/cryosparcw install-3dflex

Tail end of the install had the following output:

Processing ./deps_bundle/python/python_packages/pip_packages/pycuda-2020.1-cp38-cp38-linux_x86_64.whl
Installing collected packages: pycuda
Successfully installed pycuda-2020.1
NOTE: Installation of 3D Flex dependencies succeeded, but PyTorch or NVIDIA GPU were not detected.
This is expected at this point of the installation process.
Please confirm the installation by running a 3D Flex job.