Problems updating to 2.12

closed

#1

I just tried to update to version 2.12 and during updating I got:

 Preparing to install all pip packages...
  ------------------------------------------------------------------------
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-JSONRPC-0.3.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/Flask-PyMongo-0.5.1.tar.gz
Processing ./deps_bundle/python/python_packages/pip_packages/libtiff-0.4.2.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-XR7Qnb-build/setup.py", line 77, in <module>
        from numpy.distutils.core import setup, Extension
    ImportError: No module named numpy.distutils.core
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-XR7Qnb-build/
You are using pip version 9.0.1, however version 19.3.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
  ------------------------------------------------------------------------

I had this previously as also discussed here when updating. Then I had another conda installation. But this is not the case now.

cryosparcm forcedeps gives the same error. Any idea?


#2

Update:
even reinstall gives the same error message


#3

Hi,
I get this same error… But then it continues the installation seemingly fine and says "successfully updated master from version v2.11.0 to version v2.12.2.

However then when starting the cryosparc system master process… I get this: line 398: supervisorctl: command not found.

And then everything stops :frowning:
Any suggestions on what to do would be great :slight_smile:


#4

I got it running. By the following: I removed every other conda or Python installation from the computer (preveously I tried with only deactivating and changing the PATH variable which was fine for the last update but now not anymore.) After removing everything. I restarted the computer and run
cryosparcm forcedeps

And then it worked.


#5

i just got mine working too :slight_smile:
i followed this: