NU-refine ignores "initial batchsize" parameter


I would like to force NU-refine to use all images in the initial iterations. I thought that setting the “Initial batchsize” parameter to a number larger than the number of particles in the dataset would do this, but it does not - it seems to be completely ignored. This seems like a bug?

Similarly, setting the “batchsize epsilon” parameter to a very low number (e.g. 1e-11) seems to make little (but non-zero) difference.

The only thing that does work for this use case is to set the “batchsize snrfactor” parameter to an arbitrarily large value - in this case it behaves as expected, using all images from the start.


Thanks for reporting @olibclarke – this is indeed a bug. Added to our list to fix.

1 Like