Non Uniform Refinement Job failed

Hi all,
I am new to cryosparc and am having some issues with starting NUR job. I am using the extracted particles as my input particles and the ab initio map for the volume and each time the job fails with the message below. I would really appreciate the help of anyone who has encountered this issue or know how to fix it.

 [CPU: 255.2 MB]  Traceback (most recent call last):
  File "cryosparc_worker/cryosparc_compute/", line 84, in
  File "cryosparc_worker/cryosparc_compute/jobs/nonuniform_refine/", line 85, in
  File "/opt/usershared/software/cryosparc/cryosparc_worker/cryosparc_compute/", line 31, in initself.from_dataset(d) # copies in all data
  File "/opt/usershared/software/cryosparc/cryosparc_worker/cryosparc_compute/", line 473, in from_dataset
    if len(other) == 0: return self
TypeError: object of type 'NoneType' has no len()

Hi @Angemyr,

Can you take a screenshot of the tree view of your workspace?

Hi Stephan,
Thanks for your prompt reply. CryoSparc_troubleshooting|690x401

Hi @Angemyr,

No problem. This is odd, can you try taking the particle outputs from Class 2D and trying the Non-Uniform Refinement again?

Also, did you happen to run the “Clear Intermediate Results” function at all on this project?

Hi Stephan,
I don’t think I ran the clear intermediate results.
Also, when I tried using the selected particles from the 2D job I get a different error message saying that the particles could not be found.

Can you send a screenshot of the “Inputs” tab of the job that is failing?

I am re-starting the job from the particle extraction and made sure that I did not delete the necessary files because nothing I tried seems to work. Will keep you posted.