--nogpu still tries to install pycuda on v4.1.2 worker

We’re trying to install the CryoSPARC worker package on a CPU-only system with the --nogpu option. However, the install always fails at the following:

 In file included from src/cpp/cuda.cpp:4:
      src/cpp/cuda.hpp:14:10: fatal error: cuda.h: No such file or directory
         14 | #include <cuda.h>
            |          ^~~~~~~~
      compilation terminated.
      error: command '/usr/bin/gcc' failed with exit code 1
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: legacy-install-failure

× Encountered error while trying to install package.
╰─> pycuda

We have no need of pycuda on this machine since it doesn’t have any GPUs. Adding a GPU is not feasible since it is a 1U server with minimal space available.

Not to push, but the issue still occurs. Is there a way to exclude pycuda from a worker install?

I have CUDA installed on a system with no nVidia GPU (you don’t need a GPU to run nvcc). It’s failing because it can’t find a CUDA header, if you install the CUDA toolkit (not the drivers) will installation proceed?

Same error, even after installing the cuda toolkit. Plus, installing cuda shouldn’t be necessary for a non-gpu install anyways.

As far as I am aware, --nogpu is not a supported option for the cryosparc_worker/install.sh command.

In my test after a runfile-based installation of CUDA-11.8 on a non-gpu node, I did not encounter

when I ran crysparc_worker/install.sh ...

I was running CUDA 11.7.1 (offline runfile) on Ubuntu 22.04 (which is what our GPU nodes use). Removing --nogpu gives the same error.

The error occurring regardless indicates a deeper underlying issue.

What are your $PATH and $LD_LIBRARY_PATH environment variables? Output of which nvcc? nvcc --version?

hey, I believe that the issue can be with cuda12, according to this:

I tried installing cryosparc v4.1.2 and v4.2.1 on cuda12.1 and failed while installing pycuda with the same error as you. But when I discovered this issue and used cuda11.8, everything worked fine!