Motioncor2 failed to output file


I am trying to run motioncor2 on cryosparc 2.15.0. However, I run into the following error:

[CPU: 182.1 MB] Processed 0 of 2 movies in 0.01s

[CPU: 182.1 MB] Raw movie filepath located at: J1/imported/20jul30a_510sT_00003gr_00037sq_00002hl_00002es.frames.tif - creating MotionCor2 command string…

[CPU: 3.69 GB] Finished creating MotionCor2 command string in 8.19s

[CPU: 3.69 GB] Starting MotionCor2 process…

[CPU: 3.69 GB] Running MotionCor2 command: /apps/motioncor2/1.2.1/motioncor2 -InTiff /net/jiang/scratch/cryosparc/data/sun647/P216/J1/imported/20jul30a_510sT_00003gr_00037sq_00002hl_00002es.frames.tif -OutMrc /net/jiang/scratch/cryosparc/data/sun647/P216/J2/motioncorrected/1606766707880345660_20jul30a_510sT_00003gr_00037sq_00002hl_00002es.frames_motioncor2_aligned.mrc -Gain /net/jiang/scratch/cryosparc/data/sun647/P216/J1/imported/20jul30a_30153507_01_11520x8184_norm_0_mod.mrc -Patch 5.0 5.0 -FmRef 10 -Kv 300.0 -PixSize 0.539 -FmDose 1.11875 -FtBin 0.5 -Gpu 0 -GpuMemUsage 0.5 -LogFile /net/jiang/scratch/cryosparc/data/sun647/P216/J2/motioncor2_logs/0

[CPU: 3.69 GB] Running process 4065948

[CPU: 3.69 GB] ERROR motioncor2 failed to produce output file /net/jiang/scratch/cryosparc/data/sun647/P216/J2/motioncorrected/1606766707880345660_20jul30a_510sT_00003gr_00037sq_00002hl_00002es.frames_motioncor2_aligned.mrc

[CPU: 3.69 GB] Finished MotionCor2 process in 0.20s

[CPU: 3.69 GB] Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 85, in
File “cryosparc2_compute/jobs/motioncorrection/”, line 373, in run_motioncor2_wrapper
with open(output_path_abs) as mrc_file:
IOError: [Errno 2] No such file or directory: u’/net/jiang/scratch/cryosparc/data/sun647/P216/J2/motioncorrected/1606766707880345660_20jul30a_510sT_00003gr_00037sq_00002hl_00002es.frames_motioncor2_aligned.mrc’

It is not very informative of why the motioncor2 failed to output the file. Can anyone help me out?


Hi Chen,

for what ever reasons if the import job is on workspace W1 and the motioncor2 job runs on W2, I get the same error message as you describe in here. If I do an import job in W2 and then run motioncor2 in W2, it works.