Motion correction failure in v2.13

Motion correction on empiar subset sample data, fails at the end, missing reference to micrographs.micrograph_thumbnail_blob_1x
The same job succeeds after downgrading back to v2.12.4

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 78, in
File “cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/”, line 349, in
File “cryosparc2_worker/cryosparc2_compute/jobs/motioncorrection/”, line 285, in
File “cryosparc2_compute/jobs/”, line 442, in output
result = com.query(job[‘output_results’], lambda r: r[‘group_name’] == group_name and r[‘name’] == name, error=“No output result named %s.%s in job.” % (group_name, name))
File “cryosparc2_compute/jobs/”, line 349, in query
assert res != default, error
AssertionError: No output result named micrographs.micrograph_thumbnail_blob_1x in job.

1 Like

Hi @Juno,

Did you start a new job? Clearing an existing job and re-running it would cause this error. If that doesn’t work, run cryosparcm cli "refresh_job_types()"

I have the same issue, and I even created a new session for the processing of the data with the same error.

I started a new test run from scratch. Movies were imported with v2.13, then a new motion correction job created. – I assume this would be easy to reproduce, I’m using the distributed empiar test data.

1 Like

Hi @Juno, @stavros,

Can you follow this post:

1 Like

SOLVED… OK, I did “cryosparcm stop” and found that supervisord was still running, with a run time that meant it never stopped at the last upgrade/downgrade. The problem seems to have been supervisord not being shut down correctly, which I think has happened before. Stopped all processes, repeated the upgrade, and now it’s all working. But also the release updated to 2.13.2