ModuleNotFoundError: No module named 'pycuda'

I am trying to install Ubuntu 18.04 but I get the below error

  CRYOSPARC CONNECT --------------------------------------------
  Attempting to register worker machinea to command machinea:39002
  Connecting as unix user usera
  Will register using ssh string: usera@machinea
  If this is incorrect, you should re-run this command with the flag --sshstr <ssh string> 
  Connected to master.
  Current connected workers:
  Autodetecting available GPUs...
Traceback (most recent call last):
  File "bin/", line 233, in <module>
    gpu_devidxs = check_gpus()
  File "bin/", line 107, in check_gpus
    num_devs = print_gpu_list()
  File "bin/", line 24, in print_gpu_list
    import pycuda.driver as cudrv
ModuleNotFoundError: No module named 'pycuda'

I followed an advice in another question and someone suggested trying to install pycuda using

pip install ‘/home/usera/cryosparc/cryosparc_worker/deps_bundle/python/python_packages/pip_packages/pycuda-2020.1.tar.gz’ --no-cache-dir
and this is the output:

Processing /home/usera/cryosparc/cryosparc_worker/deps_bundle/python/python_packages/pip_packages/pycuda-2020.1.tar.gz
Collecting appdirs>=1.4.0 (from pycuda==2020.1)
Collecting decorator>=3.2.0 (from pycuda==2020.1)
Collecting mako (from pycuda==2020.1)
  Downloading (75kB)
    100% |████████████████████████████████| 81kB 7.6MB/s 
Collecting pytools>=2011.2 (from pycuda==2020.1)
  Downloading (63kB)
    100% |████████████████████████████████| 71kB 39.9MB/s 
Collecting MarkupSafe>=0.9.2 (from mako->pycuda==2020.1)
Collecting numpy>=1.6.0 (from pytools>=2011.2->pycuda==2020.1)
  Downloading (13.4MB)
    100% |████████████████████████████████| 13.4MB 144.3MB/s 
Collecting dataclasses>=0.7 (from pytools>=2011.2->pycuda==2020.1)
Installing collected packages: appdirs, decorator, MarkupSafe, mako, numpy, dataclasses, pytools, pycuda
  Running install for pytools ... done
  Running install for pycuda ... done
Successfully installed MarkupSafe-2.0.1 appdirs-1.4.4 dataclasses-0.8 decorator-5.1.0 mako-1.1.5 numpy-1.19.5 pycuda-2020.1 pytools-2021.2.8

then I run the install command again and I get the same error in my question.

Any advice please?