Missing blob for particles

hi all
I import mics, do patch motion, patch ctf, blob picker, inspect picks, then try to do a 2D run. I get error saying missing blob. I click the downarrow for the input particles and see “blobs” is empty. I went back to the outputs of prev runs but can’t find blob for particles… and blob micrographs won’t drag over. Any suggetions? thanks.

Hi @orangeboomerang, the Inspect Picks job doesn’t automatically extract the particles. To do so, connect Inspect Picks → Extract from Micrographs → 2D Classification.

Hope that helps!


how silly of me. So sorry. Was clearly rushed.

I did the extract. Worked fine. When I use the particles output for a 2D run I get the error below.

Traceback (most recent call last): 
File "cryosparc2_worker/cryosparc2_compute/run.py", line 82, in cryosparc2_compute.run.main 
File "cryosparc2_worker/cryosparc2_compute/jobs/class2D/run.py", line 64, in cryosparc2_compute.jobs.class2D.run.run_class_2D 
File "cryosparc2_compute/particles.py", line 61, in read_blobs u_blob_paths = cache.download_and_return_cache_paths(u_rel_paths) 
File "cryosparc2_compute/jobs/cache.py", line 129, in download_and_return_cache_paths other_instance_ids = get_other_instance_ids(instance_id, ssd_cache_path) 
File "cryosparc2_compute/jobs/cache.py", line 250, in get_other_instance_ids all_instance_ids = [p for p in os.listdir(ssd_cache_path) if os.path.isdir(os.path.join(ssd_cache_path, p)) and p.startswith('instance_')] 
File "/home_local/cryosparc/cryosparc2_worker/deps/anaconda/lib/python2.7/posixpath.py", line 73, in join path += '/' + b UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 8: ordinal not in range(128)

Hi @orangeboomerang, apologies for the delay.

This error indicates that either the SSD path is incorrectly set or there is an unexpected file in the SSD cache folder that is preventing cryoSPARC from reading its contents.

In the cryoSPARC web interface, go to the page Resources page (link at the bottom of the page) and select the “Instance Information” tab.

Under the entry for the worker you’re using, check the “Cache path” and ensure it is correctly set. It should have an absolute path value like /scratch/cryosparc. On the machine where cryoSPARC is installed, check this path for any unexpected or temporary files/folders with special characters in the name. You should delete these or move them elsewhere.

If that doesn’t work or if the cache path is wrong, reconnect the worker with per these instructions (use the --update flag with bin/cryosparcw connect to update an existing worker):

If neither of those strategies work, send me this information about your system for further troubleshooting:

  • The kind of cryoSPARC installation (Workstation, Master/Worker, or Cluster)
  • What kind of SSD drive you have (make/model) and how much space is available
  • What other HPC or scientific software you have running on the system, including any software that may also access the SSD.

Hope that helps,


1 Like