Migration to new standalone machine wrong hostname


I migrated a standalone cryosparc instance to a new host. cryosparcm cli “get_scheduler_targets()” showed the old host so I ran cryosparcm cli “remove_scheduler_target_node(‘oldhost’)” and now get_scheduler_targets is empty. How do I regenerate the scheduler target for a standalone instance?

Thank you!

I think you can just re-connect the worker as described here:

So you simply go to your cryosparc_worker folder, and execute the
./bin/cryosparcw connect [..]

with the new hostname.

Choose the values appropriately, and it should connect to the master.

If you have a custom hostname, the best would be to add this to /etc/hosts, so the name resolving is fast.


ps. this assumes, that the master node installation and configuration is fine. AFAIK, it does not make a difference for a worker to be on the same host or remote, the connection is done via connect.

I tried:
cryosparcw connect --worker localhost --master localhost --port 39000 --ssdpath /scratch/cryosparc_cache/ --lane default
/opt/cryosparc/gpu08/cryosparc_worker/bin/cryosparcw: line 67: config.sh: No such file or directory

Thus it appears that my install was failing. I reinstalled and it appears all is working now. Thanks for your help.

1 Like