Master try to SSH worker on single workstation

Hi everyone,

I encountered a weird error during cryosparc update. After I manually update the worker, I tried to connect it back to the master using command:

./cryosparcw connect --worker localhost --master localhost --port 39000 --ssdpath /scr --lane default --newlane

The instance did show on the web-server. However, when I tried to run jobs such as 2D classification, the job failed due to the following reason:

License is valid.

Launching job on lane default target localhost …

Running job on remote worker node hostname localhost

Failed to launch! 255
ssh_askpass: exec(/usr/bin/ssh-askpass): No such file or directory
Host key verification failed.

It seems the master node is trying to ssh to the worker node, which I don’t think it should go in that way. Is there any idea why this would happen on the single workstation connecting manner, and how to fix it?

Some info about my workstation:
NVIDIA driver 515, cuda 11.6, cryosparc 4.1.1

I agree, in principle :grinning:. ssh connection to the worker can be circumvented if CRYOSPARC_MASTER_HOSTNAME and worker hostname match. If you do not plan to connect another worker, you can try:

  1. cryosparcm stop
  2. define
    export CRYOSPARC_MASTER_HOSTNAME=localhost
    export CRYOSPARC_HOSTNAME_CHECK=localhost
    inside /path/to/cryosparc_master/ (details)
  3. cryosparcm start