Manual picking interactive job does not launch

Hi all,

I just upgraded my cryosparc version to v2.14.2, and initially everything seemed fine. This was on a GPU-workstation that has been running cryosparc for a while now (but I can’t remember the previous version number now).
Initially everything seemed fine. We tried importing micrographs, running CTF-estimation, performed manual micrograph curation interactively, everything seemed fine.
However, when we try manual particle picking, no matter which dataset we try to use we see the same behavior… essentially, the manual picking job will hang forever.
The last output I see from the interactive log is:
[CPU: 202.8 MB] Interactive job running on port 46761
[CPU: 203.9 MB] Calculating intensity for each exposure…

but when I check the job log for the manual particle picking job, I see this:
========= sending heartbeat
========= sending heartbeat
========= sending heartbeat

which makes me think it seems like it’s waiting for something.
Typically with the interactive jobs, there is an ‘interactive’ tab that shows up (in addition to overview, inputs, outputs, etc) that indicates you can then use the GUI to proceed, but this tab never shows up.

At first I thought there was something wrong with the data, but now I’m thinking there is something wrong with our cryosparc installation. Anyone see anything similar or can help us out?

I just tried downgrading to cryosparc v2.14.0 and manual picking still fails to launch.
We also have a machine running cryosparc v2.14.1 which we have been able to run manual picking on successfully (that server has power issues and is being taken down) which now makes me think there’s something wrong with my specific configuration on my GPU workstation… but it’s unclear where the problem is… any ideas for what to try next?

huh. weird… I downgraded to v2.12.0 and manual picking works again… :woman_shrugging:

Hi @ekellogg, glad to hear you got it working!

If you do get a chance to try 2.14 or if the issue otherwise comes up again, can you post the output from this command to see if there’s an error in the logs?

cryosparcm log command_core