Lost WiredTiger.wt file

Our database somehow was seriously corrupted after upgrading. Seems that the WiredTiger.wt file was lost. We have recent backups but when we try to restore them, the database process won’t start because it can’t find the WiredTiger.wt file.

Any help on how to restore an backup made by the “cryosparcm backup” command in this situation?

Just to confirm: you had executed
cryosparcm restore ...
and WiredTiger.wt was missing?

Yes. And the mongodb process failed to spawn. I tried to do a mongod --repair but it wouldn’t start for the same reason. We have routine backups using cryosparcm backup every 2 days. Last one we have is for Monday.

One other thing. One of the other folks had copied the database a while ago. I tried to copy it back just so we could get the mongo process up to do a proper restore but there is a checksum error in the WiredTiger.wt read.

Got it to work. Stopped cryosparc completely then
cryosparcm restore --file=pathToNightlyBackup

this gave us an empty database so we started cryosparc and then did the restore again and it came back.


1 Like