Local resolution estimation value error

I tried to run a local resolution estimation job after local refinement, however, the following error occurred.

What does that mean and what should I do?


What is your version of CryoSPARC? You may have run into this problem: ValueError: zero-size array to reduction operation minimum which has no identity

My version is v3.3.2.
I followed the solution as you attached above, and first checked my input mask which was in the range of (0, 0.2), and then I changed it to (0, 1) by running a volume tools job, and I used this mask as the input of Local Resolution Estimation, I still got the same error.

Hi @Wendy,

On CryoSPARC v3.3.2, there is a bug in the local resolution job, in that the job ignores the “mask” group and instead reads the mask from the volume’s mask_refine slot. Thus, it may still be reading the mask from the volume, which may still have the wrong range of (0, 0.2). I detailed a workaround previously here, which involves using lower level result groups.

On CryoSPARC v4+, this bug is resolved and the job will prioritize reading the mask from the separate group. Instead of the above workaround, you may consider upgrading to CryoSPARC v4 in order to resolve this issue and run local resolution jobs.


1 Like

Error solved. Thanks a lot !

Best wishes!