Limit translational search range during refinement

The particles I am working with are filaments with non-constant contrast, basically a stack of dimers, with each dimer separated from the other by a low-density interface. I want to reconstruct the interface and having trouble with cryoSPARC.

Through each steps up to and including ab-initio reconstruction, I can keep the focus on the interface by disabling the recenter option. When it comes to homogenous refinement, cryoSPARC starts nicely refining the interface, but then it always ends up shifting the map to the dimer. I tried masking, reducing the window inner and outer radius, changing the dynamic mask, centering on a monomer… Nothing worked. How do I stop cryoSPARC refinement from translating the particle?

Hey @iphan,

This behaviour is interesting because homogeneous refinement doesn’t have re-centering enabled. Are you seeing that the structure is shifting by looking at the slice plots?
If you are happy with the centering of the particle as it is output from ab-initio, you can take the volume+particles from ab-initio and feed them into a local refinement job. This will constrain the rotational and translational search, which can be accessed in the alignment parameters section. Check out our detailed guide page on the job for more information.


From the slice plots, it looks like refinement starts in the centre of the box and then shifts to the edges. The maps looks like only the dimer is being refined, with the focus away from the interface. I tried local refinement with no luck so far, I guess it’s a matter of optimizing parameters. Thanks for the hint.