Jobs halt in queue forever

Dear cryosparc devs,

I have installed cryosparc v2 on two machines with different setup.
The first one is a desktop device with one dedicated GPU/64 GB total RAM and runs flawlessly.
The second is supposed to become a workstation with 4xGTX1080/32 GB total RAM (only…) and shows that weird behavior. When I setup light jobs like importing data or selecting classes everything is fine. As soon as I submit heavy jobs, i.e. 2D classification, 3D refinement etc. the jobs are stuck in queue forever.
I already read about a hard-coded lower limit in RAM for cryosparc v1, is that true in v2 as well? If so, how can I override it?
Even small subsets of binned particles (1GB, 25k particles, 100x100 box) don’t run, despite the fact they should fit the memory.

Thanks in advance for help.


We also have a similar problem.
Try to specify cryosparc to use only a single GPU.
That worked for us.
We couldn’t utilize more than a single GPU so far.

Hi Tarek,

Please navigate to the “Resource Manager” tab at the bottom of the screen and inspect the “Job Queue” screen. Is there a message under your queued job? Sometimes this message may suggest a larger underlying issue. For example:


thanks for input but tried that without success before.

Hi Stephan,
it is stated as “launched” in the resource manager but actually I can see in top and nvidia-smi that nothing is running.