Job halted in queue status right after installation

I installed cryosparc as single workstation mode as followings.

./ --standalone --license <>–worker_path /user/cryosparcuser/cryosparc/cryosparc_worker --cudapath /usr/local/cuda --ssdpath /scratch/cryosparc_cache --initial_email <> --initial_password <> --initial_username <> --initial_firstname <> --initial_lastname <>

After installation I tried to run T20S tutorial.
However, for some reason, job is stuck in queue and gave a error message as followings

ServerError: Traceback (most recent call last): File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 150, in wrapper res = func(*args, **kwargs) File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 1861, in scheduler_run scheduler_run_core(do_run) File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 1953, in scheduler_run_core ‘lane’ : lanes[0][‘name’], IndexError: list index out of range The above exception was the direct cause of the following exception: Traceback (most recent call last): File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 150, in wrapper res = func(*args, **kwargs) File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 5121, in enqueue_job scheduler_run() File “/home/<>/cryosparcuser/cryosparc/cryosparc_master/cryosparc_command/command_core/”, line 157, in wrapper raise ServerError(s.getvalue(), code=400) from e flask_jsonrpc.exceptions.ServerError

I thought ssd path was wrong, so tried to re-install without ssd option.
So i delete database, worker, master folder and re-install them as followings

./ --standalone --license <>–worker_path /user/cryosparcuser/cryosparc/cryosparc_worker --cudapath /usr/local/cuda --nossd --initial_email <> --initial_password <> --initial_username <> --initial_firstname <> --initial_lastname <>

However, I got the exact same error message.
What am I suppose to do.

Welcome to the forum @Hong.

This message suggests that the “connection” of your cryoSPARC instance’s worker component may have failed. There are various possible reasons.
Can you confirm that

  1. --worker_path /user/cryosparcuser/cryosparc/cryosparc_worker was part of the actual installation command and that
  2. the file /user/cryosparcuser/cryosparc/cryosparc_worker/bin/cryosparcw exists?


  1. Yes. --worker_path /<>/cryosparcuser/cryosparc/cryosparc_worker was part of the actual installation

  2. Yes, cryosparcw exists!

I re-installed cryosparc and followings are installation settings

This is error message

It seems the worker connection, which in --standalone mode is supposed to happen automatically, has failed.
If the command
cryosparcm cli "get_scheduler_targets()"
prints [] to the screen, you may want to retry worker connection like this while cryoSPARC is running:

/home/<username>/cryosparcuser/cryosparc/cryosparc_worker/bin/cryosparcw connect \
--worker <fqdn> --master <fqdn> --port 40000 --nossd

(where <username> corresponds to the redacted username and <fqdn> to the redacted Master Hostname.
and let us know any error messages you observe.
(edited to correct the cryosparcw command)

cryosparcm cli “get_scheduler_targets()”
This command prints [] to the screen.

This message came out.

It seems the cryosparc_worker installation failed at an earlier stage than I had thought.
Inside a shell, please

cd /home/<username>/cryosparcuser/cryosparc/cryosparc_worker/


./ --license <your CRYOSPARC_LICENSE_ID> --cudapath /usr/local/cuda

If this command succeeds, please follow up with

/home/<username>/cryosparcuser/cryosparc/cryosparc_worker/bin/cryosparcw \ 
connect --worker <fqdn> --master <fqdn> --port 40000 --nossd

What does
cryosparcm cli "get_scheduler_targets()"
show after running these commands?

1 Like

It works!

You are the best!

I really appreciate it!!