Issue with creating initial cryoSPARC user

Dear All

I am trying to install cryosparc from the first time have managed to successfully install it, however i am having trouble to access the web app as i cant create the initial cryosparc user. I tried several suggestions from this forum and I am pretty much stuck here. I get the below error and would be great to get some help to sort this issue.

Creating user aravindan with email: XXXX@XXX.XX password: XXXXX and name: XXX XXX
Traceback (most recent call last):
  File "/home/aravindan/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/home/aravindan/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/", line 85, in _run_code
    exec(code, run_globals)
  File "/home/aravindan/cryosparc/cryosparc_master/cryosparc_compute/", line 89, in <module>
  File "<string>", line 1, in <module>
  File "/home/aravindan/cryosparc/cryosparc_master/cryosparc_compute/", line 62, in func
    assert False, res['error']
AssertionError: {'code': 500, 'data': None, 'message': "OtherError: sf-1:39001: [Errno 111] Connection refused, Timeout: 30s, Topology Description: <TopologyDescription id: 6107fc30438ed16263909c86, topology_type: Single, servers: [<ServerDescription ('sf-1', 39001) server_type: Unknown, rtt: None, error=AutoReconnect('sf-1:39001: [Errno 111] Connection refused')>]>", 'name': 'OtherError'}


Hello @aravie,

I would investigate this:

Some ideas:

  • You are trying to create the user “aravindan” from the wrong account (try with the same account you used to install cryosparc)
  • You have no rights to access to the database where the server runs.

Is “aravindan” the user you used to install cryosparc? did yo try

cryosparcm createuser --email your-email@something --password PASSWORD --name "Firstname Lastname"



Hello @jucastil

thanks for your suggestion. I have infact used the same username in both and have tried your suggestion too, but that comes back with “Improper usage” error message. I think this is not liked by the program without --username input.


Sorry that was the old command… the last one (v.3.2.0) looks like this:
cryosparcm createuser --email "email" --password "password" --username "username" --firstname "Firstname" --lastname "Lastname"
But I guess you know that, right? :slightly_smiling_face:

Hi @aravie, were you able to resolve this or are you still encountering issues?

- Suhail

Hi @sdawood yes i did eventually solve the issue, apologies for not updating.

I wasnt able to fix the problem any other way so, in the end i ended up reinstalling the OS and somehow it worked first time after that. Also thanks to @jucastil for the suggestions.


Hi @aravie, glad you were able to get it working!