Invalid worker executable path with cluster connect in v4.0


i just updated a cluster script ram config and wanted to do normal

cryosparcm cluster connect

but it failed with

ServerError: Invalid path to worker binary executable
Traceback (most recent call last):
  File "/home/cryosparcuser/cryosparc_master/cryosparc_command/", line 139, in wrapper
    res = func(*args, **kwargs)
  File "/home/cryosparcuser/cryosparc_master/cryosparc_command/command_core/", line 1620, in add_scheduler_target_cluster
    assert os.path.isfile(worker_bin_path), "Invalid path to worker binary executable"
AssertionError: Invalid path to worker binary executable

Worked before in 3.3.2 like this.
Do i understand correctly that the server is checking if the file exists? because the instance server doesnt see the file cause its local to compute nodes.


Hi @KiSchnelle,

You are correct that the connect function is checking if the worker binary exists. This is a bug that will be fixed in an upcoming patch. As a workaround in the meantime, is it possible to make the worker executable accessible to the instance server? Otherwise an empty executable file at the same path would also work.

created and empty file, then it also had to be executable, so i did that and then it worked.

Another point though it only outputs now

Successfully added cluster lane XXX

Before you got basically a recap of your configuration, i personally liked that, sometimes saw a typo. Could we get that back?:smiley:


@KiSchnelle This fix is included in v4.0.1

Updated and fix confirmed:)

Thanks a lot! Can be closed.