Invalid directive while running "cluster validate" script

I’m new to CryoSPARC and tried my hand at installing it. Hopefully I followed the instructions carefully, but when I run “Test Worker GPUs”, I get the following error:

Cluster job submission failed with exit code 255
sbatch: error: Invalid directive found in batch script: project_uid

What confuses me is that looking at the cluster submission script in the Event Log, the following line from the

#SBATCH --job-name=cs-gpu-sh02-12n04-{{ project_uid }}-{{ job_uid }}

was properly replaced with

#SBATCH --job-name=cs-gpu-sh02-12n04-P1-J3

Clearly the project_uid was appropriately utilized, but it still throws an error. May I ask where the issue may be coming from? Thanks so much in advance!

Welcome to the forum @jnoh2.
Please can you post the output of the command

cryosparcm cli "get_scheduler_targets()"

Thank you! I was able to resolve the issue. I had replaced

"qsub_cmd_tpl" : "sbatch {{ script_path_abs }}"

in cluster_info.json with the absolute path to my Putting back {{ script_path_abs }} instead of the absolute path resolved the issue.

1 Like