Internal server error

Hi, all.
I got error during installation of cryoSPARC on my new PC.
OS is centOS7, CUDAversion is 10.2.
The error messages are below.

I checked background process.
ps -ax |grep supervisord
And I confirmed the processes are not working.

I also have tried to restart cryoSPARC and reboot my PC.
But I got same error messages.

Do you have any ideas to solve this problem?


Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: started
command_core: started

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

command_vis: started
command_proxy: started
webapp: started

Startup can take several minutes. Point your browser to the address
and refresh until you see the cryoSPARC web interface.

Creating the initial cryoSPARC user…

Creating user xxx xxx with email: password: xxxxx
*** command (http:// xxx:39002/api) did not reply within timeout of 300 seconds, attempt 1 of 3
*** command (http:// xxx:39002/api) did not reply within timeout of 300 seconds, attempt 2 of 3
*** command (http:// xxx:39002/api) did not reply within timeout of 300 seconds, attempt 3 of 3
Traceback (most recent call last):
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/cryosparc2_compute/”, line 82, in
cli = CommandClient(host, int(port))
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/cryosparc2_compute/”, line 33, in init
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/cryosparc2_compute/”, line 61, in _reload
system = self._get_callable(‘system.describe’)()
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/cryosparc2_compute/”, line 49, in func
r =, data = json.dumps(data, cls=NumpyEncoder), headers = header, timeout=self.timeout)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/requests/”, line 116, in post
return request(‘post’, url, data=data, json=json, **kwargs)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/requests/”, line 60, in request
return session.request(method=method, url=url, **kwargs)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/requests/”, line 533, in request
resp = self.send(prep, **send_kwargs)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/requests/”, line 646, in send
r = adapter.send(request, **kwargs)
File “/home/cryosparc_user/lib/cryoSPARC/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/requests/”, line 516, in send
raise ConnectionError(e, request=request)
requests.exceptions.ConnectionError: HTTPConnectionPool(host=‘tom33’, port=39002): Max retries exceeded with url: /api (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7fe2175a3b90>: Failed to establish a new connection: [Errno -2] Name or service not known’,))

1 Like

I recently have the same error, did you figure out a solution?

Dear UNCuser

I could not solve this problem on new PC.
So, now I’m using cryoSPARC on another PC.


1 Like

Thanks for getting back to me in my moment of despair.

I was able to find a solution for my issues- maybe you or others find it useful:


Dear UNCuser

Thanks for your reterning the comment.
Finally, I solved this problem.
The cause is that REAL hostname was different from a hostname called by cryoSPARC, like aaa and AAA.
So, I added the cryoSPARC hostname into /etc/hosts file, as below. <tab_space>cryoSPARC hostname

Then, I could run cryoSPARC.


1 Like