Installation stopped - Python issue?

We were trying to reinstall cryosparc after replace a motherboard on our computer. However, we got stuck in the stage where the Python package is being installed/updated. Notably, we got the following errors:

Requirement already satisfied: bumpy in ./anaconda2/lib/python2.7/site-packages(from pylbfgs== (1.11.2)
distributed 1.22.0 requires msgpack, which is not installed.
Installing collected packages: pylbfgs, pyyaml, diskcache, pymongo, nvidia-ml-py, pycrypto, psutil
Found existing installation: PyYAML 3.13
Cannot uninstall ‘PyYAML’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
You are using pip version 10.0.1, however version 18.0 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

We are running CentOS 7. We have also installed msgpack as well as upgraded pip to version 18.0 but still get these error messages.

Any ideas on how to resolve this problem?


Update2 :

We just tried uninstalling PyYAML using pip but we still get the same error message.

I was asked by a scientific user to install this on their Centos 7 machine, and ran into the same issue. I tried on fresh installs of Centos 7 and Ubuntu Server 18.04 with no differences.

I tried updating the pip that comes with this install and then running the install again, still no resolution. This definitely feels like an issue with the install software and not the machine it’s going on.

I also ran into the same problems today. I have removed PyYAML and updated pip and still got the same error messages. Any input to fix this problem is greatly appreciated. (Running CentOS 7-1804).
Thank you!

For whatever reason, it works this morning. I was able to install cryoSPARC on two different machines. Thank you very much!

Hi! I am still suffering this problem. OS: CentOS 7.5-1804.
When I ran the install script, it quit abnormally with the error: “Cannot uninstall ‘PyYAML’.It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.”


I also run into this problem on Ubuntu 18.04 LTS amd64. Thanks for any suggestion.

Just did some research. It seems like due to the pip10 issue??? Any suggestions?

What I tried in between:

  1. yum erase PyYAML
  2. pip install --upgrade pip

The first one will remove PyYAML and the second one will update pip. I don’t think they are the issues since after I had done these, it still couldn’t install cryoSPARC. However, on the next day the script just worked.

For another workstation, I didn’t even try to remove PyYAML or update pip. It also just worked on the next day.

As I am typing this, I ran the installation at a new location under a different user account and it failed (at the same errors of PyYAML and pip).

I start to think that it could be a problem at the server side, not the local machine…

Hi Everyone,

Based on the GitHub issue linked above, we’ve released a new version of the installation scripts (v0.6.5). Please remove all previous installation attempts and try again. For your reference, we’ve updated line 559 in (we now specify pip version 9.0.3 to use during the installation process, as uninstalling a distutils project via pip is deprecated in pip 10).


1 Like

The new installer works, I installed it successfully yesterday.

It worked for me as well. Thanks!