Installation error on cryosparc version 4.1 Ubuntu LInux 22.04

I am attempting to install cryosparc on my Ubuntu 22.04 Linux (standalone installation). I am a root user. The installation begins, says dependencies are being installed, then that ‘conda environment not found; this indicates that a cryoSPARC installation is either incomplete or in progress’ and then the following error pops up:

ERROR: This command can only be called by the owner of this script: rootusername. You are root!
Alternatively, set CRYOSPARC_FORCE_USER=true in cryosparc_master/ to suppress this error.

I am the owner of the script as well as all the other files/folders in both cryosparc_master and cryosparc_worker folders that were downloaded for installation (as ls -l command clearly shows) and I run ./ as a sudo user.I followed the suggestions from the error message and added this line to file in crosparc_master folder:


There was no change during the installation - I got the same error message. I noticed that after an attempt to install cryosparc the file resets (my added line EXPORT CRYOSPARC_FORCE_USER=true gets removed).

Any suggestions as to how to troubleshoot this will be greatly appreciated.


@James_UOFT Please do not install or run CryoSPARC under the root account (see guide).

1 Like

I moved the installation folder from /home/cryosparc to /home/rootusername/cryosparc and run the installer ( without root privileges - the installation seems to have been successful this time around.