Install crashes with cuda 9

The installer crashes at pycuda. I have a new box set up with the current CUDA version (9.0.176) and tried to install cryosparc.

The end of the very long error message is:

error: command ‘gcc’ failed with exit status 1


Command “/progs/cryosparc/anaconda2/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-1Kohom/pycuda/’;f=getattr(tokenize, ‘open’, open)(file);’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-nZ8OEY-record/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-build-1Kohom/pycuda/

On a different box, I upgraded CUDA from 8 to 9 but cryosparc still sees 8 (was installed with 8). I ran the reinstallpycuda option (suggested when you upgrade CUDA) but it still uses 8 (as displayed by cryosparc status).
Jobs run OK though.

Hi @istv01, unfortunately the current version of cryoSPARC with default install will not work with CUDA 9. This is due to a dependency on pyCUDA. A new version of pyCUDA that supports CUDA 9 is available. To install it in an already installed cryoSPARC version: (we haven’t tested this):

eval $(cryosparc env)
pip uninstall pycuda
pip install pycuda=2017.1.1 --no-cache-dir

If you can’t install far enough to be able to do the above, you would need to modify the install script. If you exit (ctrl+c) from the installer after it downloads the cryosparc distribution but before it starts installing, then you can open the cryosparc folder that was downloaded, find the script inside, and go to line 572, and change the pycuda version number. Then you can re-start the install script from inside the cryosparc download folder like so:

./ --license-id=<license_id> 

The license id is the alphanumeric string that is in your download email.

Let us know if that works alright.

Thanks Ali!
Modifying the install script made it work. I’m downloading the test data set now to test it out.
When importing the example data it says “license does not exist” and stops.

Perhaps the install script could check the installed CUDA version and pull down the right version of pycuda?