IndexError: list index out of range

I am sorry but I have another error:
When trying to run a refinement I receive the error ‘IndexError: list index out of range’ see below. What might be the reason?
Thanks, Dieter

Can you tell us how your dataset was set up (does the star file reference multiple different .mrc files? did you provide a path to a single mrc file when creating the dataset?)

Can you also do this:
cryosparc configure cache clear

And then try the refinement again?

Also, have you already done ab-initio reconstruction with this dataset? Did that work?

The dataset I used is from one single .mrcs file. It contains a number of trash as it was only run once through a 2D classification. It passed the ab initio run till the end. I then used it for refinement and got the error. I now run shut down cryosparc and run 'cryosparc configure cache clear 'and run the refinement again. It crashed with the same message (see below).

Launched job v3EtWB34WQ5u4bCLE
License is valid.
Job Type: superrefine Job ID: v3EtWB34WQ5u4bCLE
Assigned Slots: RAM: [0, 1, 2] GPU: [0]
Starting High-Res Refinement , Experiment ID ngajKXYWueweso6Ny
Loading Dataset …
---- Loading File Set. Type: star Path: /home/blaasd3/cryosparc/run/bulk/./local_fs/home/blaasd3/DATA/HRV2/
Loaded meta data for 129598 images.
Found raw data for 129598 images.
Loading image data…
Found references to 1 unique data files.
Cache miss for file sparcoutput/sparcdata/jobs/c23qJiwK4osK9bDRg/cryosparc_exp000056_00_final.mrc; transferring…
Total copied : 64.00 MB
Total time : 0.49 s
Average speed : 129.97 MB/s
Dataset image size is 256.
Traceback (most recent call last):
File “/home/blaasd3/cryosparc/cryosparc-compute/”, line 166, in
dataset = dataio.dataset_factory(current_dataset_params, do_cache=current_experiment_params.get(‘do_cache’, True))
File “/home/blaasd3/cryosparc/cryosparc-compute/dataio/”, line 18, in dataset_factory
File “/home/blaasd3/cryosparc/cryosparc-compute/dataio/”, line 75, in filesets_into_dataset
load_all_referenced_mrcs(dataset, dataset, load_type, do_cache)
File “/home/blaasd3/cryosparc/cryosparc-compute/dataio/”, line 158, in load_all_referenced_mrcs
mm = mrcdata[img.data_input_abspath][img.data_input_idx]
IndexError: list index out of range

I have the same error when I tried to upload my data. Is there an easy fix?

May it be that the error arises because my input mrcs are from different folders? I selected now only one of the folders and it seems to work…