Importing job failed

Hi All
I just can’t find the topics related to my problem. I am opening a new dialogue here. I want to import several jobs done in Cryosparc into a different project and its workspace. To do so, I simply followed the instructions:
Export a job
Move “jobs” directory into “imports” directory of a new project space
Click “import” in GUI to import a job.
By doing this way, I was able to import “Extract from Micrographs” job - essentially particles stacks. However, when I tried to do the same process for “Patch CTS estimation” - micrographs or “Curate Exposures”, an import failed by getting error message saying

“Unable to find data referenced by cs files”.

However, when I looked at the exported files, there were cs and csg files. So, I don’t know what went wrong. Would someone help me on this?

The environment is as follows: v3.0.1, CUDA11, Centos 7
Thanks for your help
Best Yuro

Following…I also have the same issue.

If you’re exporting a job from once instance to another by simply moving the exported folder on the disk, this may break in-project symbolic references. To ensure these are resolved correctly, I suggest archiving the exported folder with tar command and the --dereference flag (a.k.a. -h) to make sure symbolic links are correctly resolved,

In this example, an exported job from project P3 is added to the imports folder for another project, P4.:

tar -cvhf P2_J42_patch_ctf.tar ~/cryosparc/projects/P3/exports/P2_J42_patch_ctf
mkdir -p ~/cryosparc/projects/P4/imports
tar -xvf P2_J42_patch_ctf.tar -C ~/cryosparc/projects/P4/imports

Substitute ~/cryosparc/projects with the location of the project folders on disk for your system. Substitue P2_J42_patch_ctf with the folder name of the exported job. Run the commands in your terminal. Finally, in the cryoSPARC interface, import the job from the P4/imports directory.

Let me know how that goes.

1 Like

Greeting there,

I came across same problem and after I follow the instruction but still show same error as “Ubable to find data referenced by cs files”.
Here is how I did it:
tar -cvhf P17_J210_extract_micrographs_multi.tar ./P17_J210_extract_micrographs_multi (I run this command in the export/jobs folder of P17);
mkdir -p my_project/P18/imports/jobs;
tar -xvf P17_J210_extract_micrographs_multi.tar -C my_project/P18/imports/jobs (I run this command in the export/jobs folder of P17).
Was I wrong at any command running?

Thanks and best,