Import Micrographs broken in 2.12?

And it works! Thank you :heart_eyes:

1 Like

Great, Thank you!:heart:

1 Like

Seem to be working for me too.

Thank you for the fixes

Many thanks! Import Micrographs is working fine now.

It is working. Thank you

I updated to v2.12.4 a couple days ago and have been getting this error while importing .mrc files that I converted from .ser files with
This error was not thrown while I was using these files in earlier versions of cryoSPARC

KeyError: ‘skip_header_check’

Hey @armbrustered,

Can you please restart cryosparcm restart then run cryosparcm cli "refresh_job_types()"?

I updated to V2.12.4, but the bug "KeyError: ‘skip_header_check’ " still exists.

I have run cryosparcm restart and cryosparcm cli "refresh_job_types()". The following characters appear:

Hi @Peiyu-Xu,

Can you confirm you’re creating a new job and not cloning the original job that caused the issue?

If that doesn’t work, can you make sure there are no zombie processes:

cryosparcm stop
ps -ax | grep “supervisord” (kill only the process that is running from your cryosparc2 install)
ps -ax | grep “cryosparc2_command” (kill all the matching processes related to your cryosparc2 instance)
ps -ax | grep “mongod” (kill only the process running your cryosparc2 database)

e.g. kill 82681
1 Like

@stephan looks like those zombie processes were the main cause of this as *.mrc upload issue as well as other issues (such as topaz particle picker not showing up after an update, with the main issue likely being connected to spawn errors that show up during cryosparcm start). Everything is working now after killing the cryosparc jobs found with ps -ax | grep “supervisord”

Thanks for your help!

@stephan Just wondering, in general is it safe to kill mongod? I’ve been using mongod --shutdown with the db connection parameters, but kill is easier to remember :slight_smile:

Hey @DanielAsarnow,

It should be fine:

1 Like

I still have same problem with KeyError: ‘override_exp_group_id’
my cryosparc version is 2.13.2

Hi @KSJ,

Did you try running with a brand new job? Did you also make sure to check that there were no zombie processes?

I’ve run a number of files, some of which work, some of which have errors.
Examples of error file are EMPIAR-10059, EMPIAR-10240

I also met the some problem, In cryosparc v2.14.2. When I started a new job in an old project, cryosparc reported “project_uid” and it failed start. Creating new job also not work. I tried to restart cryosparc master, killed the zombie process (supervisord?), but it still reported the same error. I downgraded cryosparc to v2.11 and it successed to run new job. Is there still a bug here?

Hi @sunny1226,

Could you paste the full error traceback you received? It can help us better understand what went wrong.

- Suhail

Oh sorry… I have just fully reinstalled the instance (including the database) recently because of “exporting project” notifications cannot be cleared. And now everything seems fine. I guess there is a database corruption?

Hi @sunny1226,

You can clear notifications in the Notification Manager (found in the Resource Manager) by clicking the “clear” button next to the notification. More information can be found here:

Also, if you are still seeing your projects and jobs (and can log into cryoSPARC) your database is most likely not corrupted.