Import images error

Following the tutorial, I have downloaded the test files and tried to import the movies and gain reference into workspace. And it shows: Unable to queue P1 J1: ServerError: Scheduler error: no scheduler lanes found. Please connect a worker using ‘cryosparcw connect’.

Welcome to the forum @799040451
Please provide additional details about this CryoSPARC installation, such as commands that were executed during installation and potential error messages.
In case this CryoSPARC installation was intended as a “single workstation”, part of the installation may have failed and cryosparcw connect may have to be run manually.

Now I installed it as master node only, and it shows again. I try to use cryosparcw connect
with these commands:
./bin/cryosparcw connect --worker u2256963
–master Yu-Latitude-5520
–port 39000\

But it shows like this:

CRYOSPARC CONNECT --------------------------------------------

Attempting to register worker u2256963 to command Yu-Latitude-5520:39002
Connecting as unix user u2256963
Will register using ssh string: u2256963@u2256963
If this is incorrect, you should re-run this command with the flag --sshstr

Traceback (most recent call last):
File “bin/”, line 75, in
cli = client.CommandClient(host=master_hostname, port=command_core_port)
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/cryosparc_compute/”, line 37, in init
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/cryosparc_compute/”, line 71, in _reload
system = self._get_callable(‘system.describe’)()
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/cryosparc_compute/”, line 54, in func
r =, data = json.dumps(data, cls=NumpyEncoder), headers=headers, timeout=self.timeout)
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 119, in post
return request(‘post’, url, data=data, json=json, **kwargs)
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 61, in request
return session.request(method=method, url=url, **kwargs)
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 516, in request
prep = self.prepare_request(req)
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 459, in prepare_request
hooks=merge_hooks(request.hooks, self.hooks),
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 315, in prepare
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 449, in prepare_headers
File “/home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/requests/”, line 947, in check_header_validity
raise InvalidHeader(“Invalid return character or leading space in header: %s” % name)
requests.exceptions.InvalidHeader: Invalid return character or leading space in header: License-ID

Please can you ensure CryoSPARC is runnig, then log on to
copy the output of the command
curl Yu-Latitude-5520:39002
and post it to the forum.
Please also post the output of

  • cat /home/u2256963/cryosparc_user/cryosparc/cryosparc_worker/version
  • cat /full/path/to/cryosparc_master/version

Did this problem solved? If yes, can you provide your input. I am also getting the same problem.

Welcome to the forum @Sabab2023.
Please can you post

  • the error message(s) you are observing
  • commands you ran that caused the error message(s)
  • outputs of the commands
    cryosparcm status | grep -v LICENSE
    hostname -f
    host $(hostname -f)

Problem Solved. reinstalled cryosparc