I/O error when starting a job

solved

#1

Only recently I started to encounter a very strange I/O error with 2D classification job or ab-initio reconstruction job (I did not test with other jobs the utilize GPU, however, particle import seems to be fine). The error is as follows:
[Errno 2] No such file or directory (in a notification on the top)
Job directory /home/data0/data0/czhao/100119Krios/processing/P19/J3 is not empty (in the job log)

This problem happens with both V2.9.0 and V2.11.0.

(Note: I have checked the permission of all folders and files in the database or in the workspace and they all belong to the current user).

I would really appreciate if you could give me any suggestion.


#2

Hi @chenzhao,

Have you checked inside /home/data0/data0/czhao/100119Krios/processing/P19/J3? Is it empty? Can you create a brand new job (doesn’t matter which kind) and see if the same error shows up?


#3

Hi @sarulthasan,

I have tried it multiple times with different jobs, and I have even created new workspace a couple of times, but the error keeps popping up. I really don’t understand why this is happening. I appreciate any further inputs.


#4

I finally solved the issue by completely reinstall cryosparc in a different folder, then rename the folder to its original name. The error is probably caused by mis-reference somewhere that uses the name of the root directory.