I can't enter the http://<workstation_hostname>:39000

i have finished the Quick Installation ## Single workstation. The nvidia and cuda are ok. The Installation process is ok. But, when i attempt to acess the the cryoSPARC user interface in the last steps " After completing the above, navigate your browser to http://<workstation_hostname>:39000 to access the cryoSPARC user interface", i am not sure what is the <workstation_hostname>. Is it the initial_email? And how should i acess the user interface? Thanks.

Hi @jingxinxin,

How are you accessing the machine running the cryoSPARC master component? If you have access to the GUI, you can simply open the browser and navigate to localhost:39000. Otherwise, if accessing from another computer on the same network (e.g. internal university network), if that machine has a hostname, you can access it though your computer’s browser (ask your IT staff if you are unsure what the hostname could be and if port 39000 is open to the internal network).

Alternatively, you can form an SSH tunnel from the remote machine running cryoSPARC and the computer you would like to access the interface (replace <remote_host> with your SSH configuration host):

ssh -N -f -L localhost:39000:localhost:39000 <remote_host>

You should then be able to access the cryoSPARC interface at localhost:39000 on your browser.

- Suhail

i can access the interface now by enter “localhost:39000” ! Many thanks!
Emmm… could you answer me another question please? I am poor in linux operating system…
When i import the .mrc files, there is always error like this:

Traceback (most recent call last):
  File "cryosparc2_master/cryosparc2_compute/run.py", line 78, in cryosparc2_compute.run.main
  File "cryosparc2_compute/jobs/imports/run.py", line 531, in run_import_movies_or_micrographs
    assert False, "Cannot import file of type %s (%s)" % (extn, abs_path)
AssertionError: Cannot import file of type /home/jingxinxin/cryosparc_user/projects/test/tdn0521 (/home/jingxinxin/cryosparc_user/projects/TEST/TDN0521) 

So what is the problem? I am sure the the files are .mrc files from cryo-EM imaging.

Hi @jingxinxin,

No problem, we’re happy to help! It looks like you specified a folder (tdn0521) instead of a wildcard expression. Open the file browser by clicking the folder icon next to the path parameter:

Then, paste this path and press the enter key:


You should see all the .mrc files listed in the file browser. Then, press ‘select’, set any other parameters you’d like and run the job. You should see that the job is now able to find the files.

- Suhail

hi, I meet accessing problem again…Same computer, no change in everything, but I can not access the “localhost:39000” again. It stop in the waiting page like this,

So, is there something wrong with the server? because I never changed anything in my computer.

Hi @jingxinxin,

Could you please report any errors from the browser console? You can right click, ‘inspect’/‘inspect element’, then press the ‘console’ tab.


Here is the report. Thanks very much.

Have you tried restarting the cryosparcm process? At the terminal type,
cryosparcm restart
This should restart the database, the command core and the webapp without any errors. If you run into errors, then you can check to see if there is a .sock file in the /tmp/ folder. If there is one, delete that file and restart cryosparcm.

> cd /tmp
> rm cryosparc*.sock

If this doesn’t work look for the supervisord process that maybe running and kill it.

> ps -aux | grep supervisord
Find the process ID (usually the first column after the login name). For example when I run
> ps -aux | grep supervisord
I see

> vamsee **5335** 0.0 0.0 39212 17132 ? Ss Aug13 0:03 /home/vamsee/software/cryosparc/cryosparc2_master/deps/anaconda/bin/python /home/vamsee/software/cryosparc/cryosparc2_master/deps/anaconda/bin/supervisord -c supervisord.conf

where 5335 is my process ID. I kill it by saying
> kill 5335
Restart cryosparcm as above. This generally resolves most cryosparc startup issues. Hope this helps.

1 Like