How to reinstall cryosparc v2?

Dear all,
Hi, I’ve deleted cryosparc v2 on a standalone workstation and I tried to reinstall it (yes, I know I shouldn’t, I’m sorry), but encountered a database error, the output message is as follows:
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: ERROR (spawn error)
Traceback (most recent call last):
File “”, line 1, in
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 1149, in database_names
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 491, in command
with client._socket_for_reads(read_preference) as (sock_info, slave_ok):
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 17, in enter
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 859, in _socket_for_reads
with self._get_socket(read_preference) as sock_info:
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/”, line 17, in enter
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 823, in _get_socket
server = self._get_topology().select_server(selector)
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 214, in select_server
File “/home/linhua/Programs/cryosparc2_master/deps/anaconda/lib/python2.7/site-packages/pymongo/”, line 189, in select_servers
pymongo.errors.ServerSelectionTimeoutError: localhost:39001: [Errno 111] Connection refused

even if I changed port number to 22000, 34000 etc. I still get this error message, does anyone know how to solve this problem?
Thank you!

Port 39001 is used by mongoDB. It seems that your mongoDB is not started in the new installation. According to the startup script, the mongoDB is started by supervisord.

You can test if the mongoDB daemon is running by typing the following in a shell terminal:


If this succeeds (probably won’t), type “show dbs” to see if there is a database called “meteor”.

The port 39000 is used by the http server (supervisord?). You probably have changed this to 22000, 34000. I suggest that you change it back to 39000.

In the cryosparcm script, it says:


This means that the mongoDB port is the cryosparc http port+1. So If you have changed 39000 it to 34000, you might need to change the port number in “mongo” to 34001. So changing 39000 to other number is only going to complicate things.

if you paste your supervisord.log found in the cryosparc2_master/run folder it would be helpful for people to see what might have gone wrong.