Host key verification failed


We installed a copy of CryoSparc and while we can import files, we can’t launch any refinement jobs with following errors. Any idea how to solve this problem? Our default shell is bash:

Command ‘[‘ssh’, u’XXXXX’, u’bash -c "nohup /mnt/grid/XXXXX/software/crysosparc/cryosparc2_worker/bin/cryosparcw run --project P1 --job J18 --master_hostname click --master_command_core_port 39009 > /XXXXX/XXXXX/P1/J18/job.log 2>&1 & "’]’ returned non-zero exit status 255

Running job on remote worker node XXXXX

Failed to launch! 255

(gnome-ssh-askpass:48408): Gtk-WARNING **: cannot open display: localhost:19.0
Host key verification failed.

Hi @smoothcryominal,

Googling your error brought me to this:

Please also see this guide:

I found this thread because I ran into the same error however I had no issues with ssh key configuration. The problem was my --sshstr was incorrect. It may be helpful to clarify in the documentation that the --sshstr should be the string used to connect to the worker node not the string to connect from the worker node to the master node. This might not be obvious to all since the connect script is run on the worker