Heterogenous refinement crashes (v2.13)


I wanted to run the heterogenous refinement in the new version of cryosparc2, however I have got the error:

[CPU: 2.62 GB] Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/run.py”, line 78, in cryosparc2_compute.run.main
File “cryosparc2_worker/cryosparc2_compute/jobs/hetero_refine/run.py”, line 457, in cryosparc2_compute.jobs.hetero_refine.run.run_hetero_refine
File “cryosparc2_compute/dataset.py”, line 379, in subset_idxs
newdata[field] = self.data[field][keep_idxs]
ValueError: could not broadcast input array from shape (1015) into shape (3000)

For the first try, I have used non default settings (different box size, higher lowpass resolution, more iterations). Later I tried with default settings and got the same error. Previously it worked ok. NU and homogenous refinements work without any errors.

What could be the reason for the error and is there easy way to fix it? If you need any extra information I would be happy to provide it.

1 Like

Hi @dzyla,

Thanks for reporting this bug. It looks like an issue with only multi-class ab-initio and heterogeneous refinement. We have released an update to cryoSPARC that fixes the issues you’re having (v2.13.2, January 30, 2020).

To update, run: cryosparcm update