Gain reference problems


Trying to import movies from the tutorial test set I am getting the following error:

Traceback (most recent call last):
File “cryosparc2_master/cryosparc2_compute/”, line 78, in
File “cryosparc2_compute/jobs/imports/”, line 510, in run_import_movies_or_micrographs
with open(gainref_abs_path) as mrc_file:
IOError: [Errno 2] No such file or directory: u’$HOME/test_set/empiar_10025_subset/norm-amibox05-0.mrc’

If I leave the gain reference blank I can import the movies without correction so $HOME seems to be defined correctly and if I type “ls $HOME/test_set/empiar_10025_subset/norm-amibox05-0.mrc” from a terminal I can find the file.

Any ideas?

1 Like

exactly same problem here, and I have no idea why. I have change the name and the location of the file and always the same problem

I had the same problem and it appears $HOME does not get resolved for the gain reference file. If you replace $HOME with the actual path it stands for in the file browser, cryoSPARC can access and read the file.

Problem solved by writing the complete path.

Bug still there in version 2.9 and solved as above. Thanks