Filament tracer errors

Hi everyone,

I had the same error as this Inspect pick error and I updated the CryoSparc with the new patch, now the version is v3.2.0+210803. The filament tracer worked well before updating the patch, however, after updating the patch, I have an error when I tried to start a filament tracer run.

[CPU: 624.9 MB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/”, line 84, in
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/”, line 61, in
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/”, line 249, in
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/”, line 440, in
File “cryosparc_master/cryosparc_compute/jobs/template_picker_gpu/”, line 548, in
AttributeError: ‘float’ object has no attribute 'astype’

Any suggestions on what I can do with this?


Hi @s_ann,

Thanks for reporting. This looks like a bug introduced in the latest patch, which happens when only one particle pick is found on a given filament. We’ll try to fix this soon in an upcoming patch. In the meantime, it might be possible to avoid this edge case by changing some parameters – what have you set for the filament diameter, minimum filament length, and separation distance between picks?


Hi Michael,

I set 80Å for filament diameter, 4 for minimum filament length and 20 for separation distance between picks; which I just realized that I made a mistake on the unit for the separation distance. Now that I reset the separation distance between picks to be 0.2, the filament tracer worked well. So I guess the issue is due to the separation distance. Anyway, both filament tracers and inspect particle picks seem to work well now.

Thank you for your time!


1 Like