Failed to launch! 255 after moving installation to new JBOD


I have moved the home directory of my cryosparcuser to a new disk. After some problems with getting the database working again, I could finally log in again and see all my jobs. I did an update to the latest version and now realized that I can only start jobs on my master node (the jobs work fine there). When I queue a job on the worker node I get this error:

Running job on remote worker node hostname

Failed to launch! 255
Permission denied, please try again.
Permission denied, please try again.
cryosparcuser@ Permission denied (publickey,password).

The thing is that the hostname and ip address of the worker did not change. Also the worker update did work, although I had to manually enter the password during the update.

I tried to ssh into the worker from my master when I am logged in as my cryosparcuser. That works fine.
Can anybody give me a tip on how to solve this?
Thank you!

Please can you post a screenshot of the a shell session on your master node (under the cryosparcuser account)

hostname -f
ssh cryosparcuser@ 'hostname -f && id'

Thank you for helping, @wtempel ! Here is the screenshot.

Passwordless ssh connections from cryosparcuser@hulk to cryosparcuser@ for the host at to function as a worker on this CryoSPARC instance.

Thank you! It works now!