Fail to build wheel for pycuda on fresh worker install

I am trying to do a fresh install of CryoSparc, and while I am able to install the cryosparc_master, I am not able to install the cryosparc_worker. When I try to run a cryosparc_worker install, i get the following error message about halfway through:

And then I get this error at the end:

I know that the /usr/bin/gcc failed with exit code 1 means that it doesn’t think gcc is installed, but it is.
So I then tried to install the python-devel packages, and those are all up to date.
Then I updated pip, which didn’t solve the problem either.
Finally, I specified the CUDA path, which also didn’t fix the problem.

Any ideas on how to fix this would be greatly appreciated.

Here is information about my workstation:
after running echo $PATH

Running whereis cuda:
Screenshot 2023-03-20 at 12.34.17 PM


Please post the error messages as text to make questions on this forum more “findable”.
What is the version of your CUDA toolkit:
/usr/local/cuda/bin/nvcc --version
CUDA-11.8 is currently the latest version supported by CryoSPARC.

type or paste  /usr/local/cuda/bin/nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Tue_Feb__7_19:32:13_PST_2023
Cuda compilation tools, release 12.1, V12.1.66
Build cuda_12.1.r12.1/compiler.32415258_0
code here

Welp, I think that’s my issue. Though when I was downloading it from Nvidia, it looked like I was downloading 11.7.

This is what I had installed before though, so I’m not sure if I should be changing something in the commands?

sudo rpm -i cuda-repo-rhel7-11-7-local-11.7.0_515.43.04-1.x86_64.rpm
sudo yum clean all
sudo yum -y install nvidia-driver-latest-dkms cuda
sudo yum -y install cuda-drivers

Your CryoSPARC installation may be more stable if you install the toolkit as part of
cryosparcw install-3dflex, but ensure the prerequisites of that installation method.

I already have that downloaded. I’m not sure what’s happening but when I run install cuda, it will only install 12.1 no matter what I download:

 * updates:
base                                                              | 3.6 kB  00:00:00     
centos-sclo-rh                                                    | 3.0 kB  00:00:00     
centos-sclo-sclo                                                  | 3.0 kB  00:00:00     
cuda-rhel7-11-7-local                                             | 3.0 kB  00:00:00     
cuda-rhel7-11-8-local                                             | 3.0 kB  00:00:00     
cuda-rhel7-x86_64                                                 | 3.0 kB  00:00:00     
epel                                                              | 4.7 kB  00:00:00     
extras                                                            | 2.9 kB  00:00:00     
updates                                                           | 2.9 kB  00:00:00     
(1/12): cuda-rhel7-11-7-local/primary_db                          |  56 kB  00:00:00     
(2/12): cuda-rhel7-11-8-local/primary_db                          |  57 kB  00:00:00     
(3/12): base/7/x86_64/group_gz                                    | 153 kB  00:00:00     
(4/12): centos-sclo-sclo/x86_64/primary_db                        | 300 kB  00:00:00     
(5/12): base/7/x86_64/primary_db                                  | 6.1 MB  00:00:00     
(6/12): cuda-rhel7-x86_64/primary_db                              | 1.9 MB  00:00:00     
(7/12): epel/x86_64/group_gz                                      |  99 kB  00:00:00     
(8/12): epel/x86_64/updateinfo                                    | 1.0 MB  00:00:00     
(9/12): centos-sclo-rh/x86_64/primary_db                          | 3.4 MB  00:00:00     
(10/12): epel/x86_64/primary_db                                   | 7.0 MB  00:00:00     
(11/12): extras/7/x86_64/primary_db                               | 249 kB  00:00:00     
(12/12): updates/7/x86_64/primary_db                              |  20 MB  00:00:00     
No package nvidia-drivers-latest-dkms available.
Error: Nothing to do
$ sudo yum -y install cuda
Loaded plugins: fastestmirror, langpacks, nvidia
Loading mirror speeds from cached hostfile
 * base:
 * centos-sclo-rh:
 * centos-sclo-sclo:
 * epel:
 * extras:
 * updates:
Package cuda-12.1.0-1.x86_64 already installed and latest version
Nothing to do

I’ve tried every which way to uninstall it by this point.

With 3DFlex prerequisites installed, a “system-wide”, installation of the CUDA toolkit is not required for CryoSPARC function. Under certain circumstances, presence of “system-wide” toolkit components in PATH or LD_LIBRARY_PATH definitions may interfere with the installation and use of 3DFlex prerequisites.
A possible workaround may be to

  • not install a “system-wide” toolkit
  • install versions of the toolkit as needed by various software packages without “globally” including any toolkit installation in PATH or LD_LIBRARY_PATH definitions. To avoid inadvertent system-wide configuration changes, the “runfile” of the toolkit can be installed by a non-root user with the --toolkit, --toolkitpath=, --defaultroot= parameters.