Error using CPU parallelized extraction job


When we use the new CPU parallelized extraction job in 3.1, it seems to complete without error, but if we start a 2D classification job from the resulting job it terminates with the attached error. Particles extracted using the GPU extraction job do not give this error, and we get the same error on multiple datasets.

This is using negative stain data, in case that is of relevance.


Hi Oli,

We’ve seen this a few times in 2D classification, even before parallel cpu extract, and haven’t yet established a pattern… What was the box size you’re extracting at? Is there anything else about the data itself that’s in any way unusual?


Both had different box sizes, nothing unusual about the data except that it was negative stain - and both worked fine with the regular extract job. Both gave the exact same error, despite being different projects, particle stack sizes, etc

Also have observed this with cryo data. Reverted to regular mode.

Dear all, a patch is now available that fixes this issue. Please see: Patch 210216 available for v3.1.0 - Fixes CPU extraction bug and Patch CTF bug