Error in Select 2D classes

Since we have updated to cryoSPARC 2.9.0 we get the following error when executing job “Select 2D classes”

Traceback (most recent call last):
File “cryosparc2_master/cryosparc2_compute/”, line 78, in (/home/installtest/deps_manage/cryosparc2_package/deploy/stage/cryosparc2_master/cryosparc2_compute/run.c:3954)
File “cryosparc2_compute/jobs/select2D/”, line 156, in run
if params[‘selected_templates’]:
KeyError: ‘selected_templates’

Any help is appreciated.

Hey @mazhabmt,

Is it possible if you can run the following commands on the command line?
cryosparcm restart
cryosparcm cli "refresh_job_types()"

I just tried and it did not help. Also, I got the following spawn errors when I executed the ‘cryosparcm restart’ command:

CryoSPARC is running.
Stopping cryosparc.
command_vis: stopped
webapp: stopped
Shut down
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: ERROR (spawn error)
command_core: ERROR (spawn error)
cryosparc command core startup complete.
command_vis: started
command_proxy: ERROR (spawn error)
webapp: started

CryoSPARC master started.
From this machine, access cryoSPARC at
From other machines on the network, access cryoSPARC at

Startup can take several minutes. Point your browser to the address
and refresh until you see the cryoSPARC web interface.

Hi @mazhabmt,

Your update may have went wrong. First, try seeing if you can successfully restart cryoSPARC. Follow my earlier post for details on how to ensure zombie processes are not a possibility: Mongo connection refused

Then, try starting cryoSPARC again cryosparcm start

If that still doesn’t work, force-update your instance:

I just restarted the computer and everything is working again.
Thanks for your help with this.