Error exporting accepted particle picks


I’ve just installed v2.14 and can now pick from the entirety of our K3 micrographs. However, after inspecting picks, I’m repeatedly encountering an error preventing me from accepting and outputting these particles.

[CPU: 1.52 GB]   --------------------------------------------------------
[CPU: 1.52 GB]   Outputting particles that have:
[CPU: 1.52 GB]     NCC score    >  0.410
[CPU: 1.52 GB]     Local power  >  85.000
[CPU: 1.52 GB]     Local power  <  175.000
[CPU: 2.19 GB]   644797 particles included, 1222348 particles excluded.
[CPU: 2.19 GB]   --------------------------------------------------------
[CPU: 2.19 GB]   Traceback (most recent call last):
  File "cryosparc2_master/cryosparc2_compute/", line 82, in
  File "cryosparc2_compute/jobs/manual_picker/", line 412, in run_inspect_simple
    my_particles_out = particles_out_by_micrograph[mic['uid']]
KeyError: 838431682449369516

I’ve tried restarting everything to no avail. I’ve also tried to output picks from previously uploaded and curated data from before the update.

If anybody could help with this, it’d be greatly appreciated.


Hi Mike, thanks for the report. We’ve identified the issue and are working on a fix.