Error: command 'x86_64-conda_cos6-linux-gnu-gcc' failed with exit status 1


I’m installing Cryosparc on Scientific Linux release 7.3 and it fails with the following:

x86_64-conda_cos6-linux-gnu-gcc -pthread -fno-strict-aliasing -march=nocona -mtune=haswell -ftree-vectorize -fPIC -fstack-protector-strong -fno-plt -pipe -fwrapv -Wall -Wstrict-prototypes -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/DATA/cryosparc/cryosparc_install/anaconda2/include/python2.7 -c src/MD2.c -o build/temp.linux-x86_64-2.7/src/MD2.o
unable to execute 'x86_64-conda_cos6-linux-gnu-gcc': No such file or directory
error: command 'x86_64-conda_cos6-linux-gnu-gcc' failed with exit status 1

I’d guess that the installer is supposed to install x86_64-conda_cos6-linux-gnu-gcc but isn’t as I can’t find that binary in the install location. gcc is installed.

I manually installed gcc_linux-64 using this command:

./conda install gcc_linux-64

And then got a dependency error when I reran the installer:

UnsatisfiableError: The following specifications were found to be in conflict:
  - pyfftw
  - scikit-image 0.12.3*
Use "conda info <package>" to see the dependencies for each package.

Will there be an update for the installer to fix this problem?

I reran the installer today and it installed successfully. Please close this request.


Happy New Year.

We also met same error message while installing 0.6.3. We have 2 identical GPU workstations and one installed 0.6.1 without problem. The other one gave me this unsatisfiableError when I install 0.6.3 last week. I also tried to install cryoSPARC under a new account but got same error. Can you give me some suggestions to fix it?
Thank you. (ps. I did the installation script not manual way).

Hi Kuen,

The version that finally installed for us is 0.6.1. I wasn’t able to determine a workaround.

I suggest installing 0.6.1 and then try upgrading to 0.6.3.


Hi Mick,

I actually don’t know how to install older version (0.6.1) as the install script obtained from email automatically downloads the latest version (0.6.3 now). Is there a way to do so?

Many thanks in advance.

Problem fixed. I copied the installed cryoSPARC from machine A to machine B. Then manually install the conflict package by "conda install -c conda-forge " . After few rounds of dependency checks, all packages are installed and “cryosparc start” works very well.


1 Like

Great! I was going to suggest you do that.