Error AssertionError: Get rid of patches that are too close to edges

Dear all,

I have recently tried to run Patch CTF correction for a dataset with pixel size 0.28. When trying to run it, I get the following error for all exposures:

Error occurred while processing J9/motioncorrected/010908964878863668734_18nm_0187.dm4_patch_aligned.mrc
Traceback (most recent call last):
  File "/ssd/cryosparc/cryosparc_worker/cryosparc_compute/jobs/", line 60, in exec
    return self.process(item)
  File "cryosparc_worker/cryosparc_compute/jobs/ctf_estimation/", line 112, in
  File "cryosparc_worker/cryosparc_compute/jobs/ctf_estimation/", line 118, in
  File "cryosparc_worker/cryosparc_compute/jobs/ctf_estimation/", line 119, in
  File "cryosparc_worker/cryosparc_compute/jobs/ctf_estimation/", line 1048, in
  File "cryosparc_worker/cryosparc_compute/jobs/ctf_estimation/", line 1065, in
AssertionError: Get rid of patches that are too close to edges

Marking J9/motioncorrected/010908964878863668734_18nm_0187.dm4_patch_aligned.mrc as incomplete and continuing...

I am running cryosparc version 4.0.3.

Any ideas on how to fix it would be greatly appreciated!

Thanks a lot in advance

I once had the same error message when I mistyped the pixel size in CryosparcLive. Double check all things pixel

Thank you for your reply. We double checked the pixel size and it is correct. We tried both with binned and unbinned data and both gave the same error.

CryoSPARC can struggle a bit with very high magnification data (we’ve seen the same with 0.32 Å/pix micrographs). I ended up using CTFFIND to do it.

Thank you for your reply. We unsuccessfully tried CTFFIND on v.403, but we were able to run it on v3.3.1. Might it be a bug in the new version?
Thank you in advance!

I’m not sure what version of CTFFIND ships with cryoSPARC 3.3, but the version in cryoSPARC 4.0.3 is 4.1.10. I found 4.1.10 to be a little buggy (I have a couple of datasets which it will occasionally crash on) but maybe that’s just bad luck on my part. The version which ships with the pre-compiled cisTEM binaries (4.1.9) appears to work for everything, on every system I’ve ever tried it on. The most recent release, 4.1.14, I’ve also had no troubles from.

While I don’t recommend doing this, you could back up the 4.1.10 CTFFIND executable used by cryoSPARC and replace it with the 4.1.9 or 4.1.14 to see if that works better.

Another thing which might work is manually specifying a 1x1 “patch” for the patch CTF estimation.

I can confirm that patchCTF struggles with high magnification data, though we will fix this in a future release. It is good to know that CTFFIND 4.1.10 can be flaky - please let us know if switching CTFFIND versions resolves the issue.


Thank you very much everyone, we will try other versions and update here.

@hsnyder I have now been able to confirm that switching CTFFIND version has resolved the issue! Do you have any plans in the future to update the patch CTF job type so that it can be applied to high magnification datasets? I would be quite interested in running it!

Best wishes,


1 Like

Hi Chloe,

Yes we will definitely address the high magnification issue in Patch CTF, but I can’t promise a specific timeline at the moment. Thank you for confirming that other CTFFIND versions serve as a workaround in the meantime!