Empty worksparc after attach project

Hi all,
We try to attach several projects to cryosparc after updating from v3 to v4.2.1. All these projects were copied to a different directory before update.
We encountered a problem with one project showing empty workspaces (please see the attached picutre). We tried to dettach and attach again but make no difference. We wonder if anyone who have the same problem and could kindly suggestion a solution. Many thanks.

Welcome to the forum @geyang928 .
Based on your description

I would expect that the updated instance now has two copies (under different project directory paths) for those projects that you have attached after the update. Is this correct?
Does the command_core log (/path/to/cryosparc_master/run/command_core.log, accessible via
cryosparcm log command_core) show any errors pertaining to the import of this project?

Dear wtempel,
Many thanks for your kind reply.
There is only one copy as the project folder were copied to the cryosparc folder of a differnt user who has access to the updated version.
Our major concen is we process serveral projects the same way and only this project runs into trouble showing empty workspace after attach (the structure of the worksparc is correctly unloaded but most of them has no jobs ). Any ideas how to detect the problem? I checked the project folder. The folder did contain jobs. Also the cs.lock file was created. Can I delete the lock file and try to attach again?
Wish you a nice weekend.

I would not do that before inspecting the core log file
and understanding the cause of the failure to attach.
Because you have successfully attached some projects, you can compare log entries for successful project attachments with the log entries related to the attachment of P53.

@geyang928 What happens when you

  • click View Jobs for one of the workspaces
    that should contain jobs (as confirmed in the older CryoSPARC version before copying project data)
  • then push the refresh button (circular arrows in the Statistics panel) on the right-hand side of the workspace display?

    What number is shown next to Total Jobs?

Hi wtempel,
After click View Jobs for one of the workspace, it shows one window asking to import/movies/jobs. The refresh button resulted no jobs.
I run this command: “find / -xtype l | grep -v imported | wc -l” and figure out this project has 185819 broken links. I think something happened may be during copying.
I want to copy the project folder from the original directory and try attach again. How should I proceed efficiently as the project is around 8 TB ? Should I detach and deleted the current broken folder before I do it ?
Many thanks for your kind help.

I would go ahead and detach a project that was not correctly attached.
My recommendation remains to inspect the command_core log for errors related to this project’s attachment, which may help identify a cause for the absence of expected jobs, etc.
you may also check 1 and 2 for documentation regarding symbolic links in CryoSPARC.

Hi~ I get stuck in similar problem, cannot fully attach my project, too.
cannot fully attach project