Empty/featureless classes in 2D classification

Hi all,
I am doing 2D classification on some single particle data that’s imported from Relion. An initial 2D resulted in a lot of classes that are featureless/kind of empty (see circled classes in A).
When I run 2D classification on just the empty-looking classes, they split into classes with features. (B)
So it seems like the 2D classification is classifying a lot of particles that has features into these featureless classes, which creates a problem.

For reference, when I run a 2D classification in Relion, I do not encounter this problem. The classes are not great (some edges and some empty) but most classes have a feature. (C)
I was wondering what could cause such a problem with CryoSPARC?

Also, since I only imported the particle stacks without the micrograph, is there a feature in CryoSPARC that allows me to visualize all the particles in a specific class without importing the micrographs?

Many thanks,

Welcome to the forum @cvanitnelav.
Which version (and patch, if applicable) of CryoSPARC did you use for this classification?
Please can you post higher resolution versions of the class grids so that any numbers printed on the tiles can be deciphered.

Thank you very much! I am using the newest version of CryoSPARC which is v4.2.1

This is the initial grid that contains the featureless classes, sorry for the inconvenience!

And this is the grid for when I did 2D classification on only the featureless classes (I picked 5)

Thank you very much!

Hey @cvanitnelav, sorry for the late update :slight_smile: I’ve been processing the data you sent me, and I think I’ve been able to replicate what you saw. Here’s my initial 2D classification, and then the 2D classification on the featureless classes:

I turned off class sorting by # of particles so that I can better follow the classes as they change through the O-EM iterations, and what I saw is that some of the featureless classes have features in earlier iterations, but fade into noise-like blobs by the end. Do you see something similar in your own job?

If so, others who have run into issues like this (see this post and this post) have found success with switching off the noise model, increasing the number of iterations and/or the batch size, or increasing the initial classification uncertainty factor.

1 Like

Hi @kwang,

I turned off class sorting by # of particles so that I can better follow the classes as they change through the O-EM iterations

Would it be possible to add this option to the GUI? We have often wanted it for similar reasons


1 Like

Hello @kwang ,
Thank you for your help!
Since I cannot turn off class sorting by # of particles (like @olibclarke has suggested, it would be really helpful to have this option in the GUI), I can only have a rough impression of how the classes change. I do agree that my overall impression is the same with what you gathered: the featureless classes have some features in earlier iterations, and they only start to appear in later iterations like >25.
Thank you for the suggestions from the other posts. I tried all the options and eventually I think switching off the sigma annealing completely (from the second link) helped with the situation. When I try the other methods (increasing # of iterations, increasing batch size, increasing initial classification uncertainty), the featureless classes still remain.


1 Like

Thank you for your suggestions, @olibclarke @cvanitnelav, we have recorded!

1 Like