Different particle numbers between the table and output

In a completed 3D classification job, I found that the particles number showed in the output boxes are completely different from the number in the table (class, #ptc, delta). what is the problem?

Hi @Lan. Please can illustrate the discrepancies with screenshots from the job’s Event Log.

They are the same, but you have “sort classes by population” turned on so at the end it lists them most–>least populous

I used the defaulted setting. should I change anything? Lan

no, that is the default setting. if you want it to correlate class number in the table to the outputs, then you can disable this setting. The only change is the ordering of the outputs, so results of the experiment are unchanged. I routinely disable this setting so event log matches the outputs, helping me go from results reporting to downloads/next steps in an obvious way.

Thank you! I understand it now.
I suggest the default should be off this option. Or use the identical class ID with the particles to reduce the confusion.

Hey @Lan,

FYI: class re-ordering is now default OFF in 3D Classification in CryoSPARC v4.5, released May 7, 2024. Hope that helps reduce the confusion.



Hi Valentin,
Thank you so much for noticing me personally. appreciate it! Thank you for continuing development.