Different cryosparc behavior on the same NAS when accessed from different workstations

We have been using a NFS-mounted Synology NAS drive for data processing in cryoSPARC on one of our GPU workstations, which has worked very well. However, cryoSPARC on a different workstation in the lab claims the NAS is unwritable and will neither create a project on it nor attach a pre-existing project, even though both operations worked immediately on the same NAS from our other workstation. Both workstations are running NFS 4.1, although the one on which cryoSPARC works properly with the NAS is running CentOS7, while the one that doesn’t work is running Ubuntu 18.04. The permission for both are set the same on the NAS and look the same when listed from the command line on both workstations. Here’s output from the workstation on which cryoSPARC claims the NAS is unwritable:

$  echo "testing" >/mnt/nfs_SynologyCryoEM/data/cS/test.txt
$ cat /mnt/nfs_SynologyCryoEM/data/cS/test.txt 
$ ls -lah /mnt/nfs_SynologyCryoEM/data
total 0
drwxrwxrwx 1 1024 users 16 Feb 11 21:44 .
drwxrwxrwx 1 root root  34 Feb 11 21:46 ..
drwxrwxrwx 1 1026 users 68 Feb 11 22:57 cS
drwxrwxrwx 1 1024 users 32 Jan 19 08:08 Movies

Any insight or recommendations about additional diagnostics would be tremendously appreciated. Both workstations are running cryoSPARC 4.4.1.

Hi @LoughlinColumbia, mine uses cifs instead of nfs but maybe I can help troubleshoot. Could you show the relevant line in /etc/fstab or the mount command you’re using on each system? (redacting any passwords)