Deleting a project where the folder was already deleted fails if Live session was run

We seem to have hit a minor issue when trying to remove projects that were already manually deleted (v3.1.0+210216).

When trying to delete the project from the web interface, a notification said it was unable to delete [path/to/project/]S1. Afterwards, the folder structure was apparently recreated by Cryosparc, but only the job folders. Trying to delete again still gave the same error, but manually making the S1 folder again solved the issue. With that folder in place, we could delete the project form the web interface.

Hope its a bug that can be fixed so such a project with the files missing is just removed, as it already happens for manually deleted projects without Live session folders.

Hey @boggild,

Thanks for reporting- this is definitely a bug, we’ll get it fixed for the next release.

Encountering this again today on another project, the folder structure didn’t re-appear on its own, but I still had to just manually create the S1-folder at the expected location to allow project deletion from the web interface.

edit: it seems pressing “clear intermediate results” is what can re-create the folder structure, minus the session folder(s).

Many thanks!
I deleted the empty project by creating the missed Sx folder~

The bug seems persist, not sure if there a patch already to fix this~ I am up-to-date

I’m also still seeing this on our up-to-date installation.